Home » Audio » Pro Sound » Marshall AVT150 Head problems!
Marshall AVT150 Head problems! [message #27275] Thu, 25 May 2006 19:10 Go to next message
Bradley is currently offline  Bradley
Messages: 1
Registered: May 2009
Esquire
I take really good care of the head and it has never been any trouble. I tried turning it on and it was dead the lights wouldnt even come on. I had just played the day before and unplugged it when I was done. Please Help!


Re: Marshall AVT150 Head problems! [message #27280 is a reply to message #27275] Wed, 07 June 2006 11:32 Go to previous messageGo to next message
Wayne Parham is currently offline  Wayne Parham
Messages: 17269
Registered: January 2001
Illuminati (33rd Degree)

Not to be silly, but did you try the easy stuff like fuses, breakers even making sure the outlet has power?


Re: Marshall AVT150 Head problems! [message #27458 is a reply to message #27275] Thu, 16 August 2007 16:12 Go to previous message
Cason is currently offline  Cason
Messages: 1
Registered: May 2009
Esquire
have you solved this problem yet? j/w because i recently ran into a similar problem and i tried replacing fuses and they keep blowing. any assistance would be appreciated.

Previous Topic: What cables are needed for Matchless effects loop?
Next Topic: Marshall AVT150 footswitch
Goto Forum:
  


Current Time: Tue Oct 16 06:11:23 CDT 2018

Sponsoring Organizations

DIY Audio Projects
DIY Audio Projects
OddWatt Audio
OddWatt Audio
Pi Speakers
Pi Speakers
Prosound Shootout
Prosound Shootout
Smith & Larson Audio
Smith & Larson Audio
Tubes For Amps
TubesForAmps.com

Lone Star Audiofest